+ Reply to Thread
Results 1 to 6 of 6

Thread: No fuel pump

  1. #1
    Join Date
    May 2010
    Location
    San Diego
    Posts
    11

    Default No fuel pump

    Finally finished the build, too find out I have no power too fuel pump. Checked all the connections and tapped on the fuel pump it self, nothing . I tried looking up a wiring diagram to see if it has a pump relay or something, but found nothing. I also checked the four wire plug (black and brown wire) with a multimeter and have no power when /i turn on key. Could it be anything else?

    Mark

  2. #2
    Join Date
    Apr 2007
    Location
    bakersville, NC
    Posts
    2,681

    Default

    The fuel pump relay is in the tail near the tail light. two relays back there, have fuses, check them.

    I have a new P8 in the box if you need one.

  3. #3
    Join Date
    May 2010
    Location
    San Diego
    Posts
    11

    Default

    I just tried those relays, and the left one clicks when I switch the run/stop but the right one does nothing. I switch the relays from right to left and the same happens. Still no power to plug. I would like to buy the ECU from you?

  4. #4
    Join Date
    Apr 2007
    Location
    bakersville, NC
    Posts
    2,681

    Default P8

    PM sent. I was going to suggest switching them.

  5. #5
    Join Date
    Sep 2009
    Location
    Milano - Italy
    Posts
    373

    Default

    first try to bypass the on/off switch on the right handlebar then the switch on the sidestand
    bye
    Jacknipper

    "better to reign in hell than to serve in heaven"

  6. #6
    Join Date
    May 2010
    Location
    San Diego
    Posts
    11

    Default

    Thanks everybody for all of the advice. I did all the things that everybody said and still nothing. Greenmonster sent me a pic of a spot on the circuit board that melts out the fuel pump but nothing; than I started checking all the connections in the ECU and found out that the chip was in backwards. Switched it around and the bike runs great. I feel real dumb but at least I found it. Thanks again for all of your help.. This site rules..

    Mark

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts