+ Reply to Thread
Page 12 of 12
FirstFirst ... 2 3 4 5 6 7 8 9 10 11 12
Results 111 to 113 of 113

Thread: 888 / St4 Hybrid Project

  1. #111
    Join Date
    Oct 2017
    Location
    Isle of Man
    Posts
    66

    Default

    I sent some messages to guys on another forum who have ST4S bikes and have managed to port over maps to run on the 5AM ECU

    Seems a number of them are running these maps successfully although as Brad points out, without the air pressure sensor input (and also apparently the neutral light will not work either)

    As a bonus they have managed to write these files without the immobiliser, but the fans working correctly etc. I have been sent two options, a standard map and a Ducati Performance map (for open pipes)

    I'm just waiting for the correct cable from Lonelec to turn up and will give it a go...

  2. #112
    Join Date
    Oct 2017
    Location
    Isle of Man
    Posts
    66

    Default

    Today was the day to sort out the map on the bike. To summarise:
    • ST4S Loom - modified to extend some connections (inc ECU) under the seat
    • Hypermotard 1100 (2008) 5AM ECU - chosen as I was told they do not run an immobiliser and the 5AM is easier to map later (thanks Brad!)

    I managed to speak to some guys on the .ms forum who had successfully swapped out the original ST4S ECU (Marelli 59M) for the later ECU used on Hypermotards / 1098s etc (Marelli 5AM) They had suffered with failing ECUs so did the hard work to make the later ones work!

    Using the correct cables form Lonelec, a Macbook Pro and some free (!) software called :
    • IAW5xReader_V0.28_x64
    • IAW5xWriter_V0.24

    I was able to talk to the Hypermotard ECU and download the original map (in case things went wrong..) and then upload the map the guys sent me from the other forum.

    To be certain the new map was on there I connected and downloaded again the map I had uploaded and the text file confirmed this was a different map to the original Hypermotard map.

    Holding my breath a little I started the bike and... it ran perfectly, ticks over nicely and responds crisply to the throttle - super pleased with this result !
    Attached Images

  3. #113
    Join Date
    Oct 2017
    Location
    Isle of Man
    Posts
    66

    Default

    A couple of fault codes read with GuzziDiag_V0.47 to sort out but otherwise all good

    The map is lacking input for the air pressure sensor so I suspect one of the codes is that

    TPS probably needs a reset too as I 'think' 3.20 is a little low..
    Attached Images

+ Reply to Thread

Similar Threads

  1. FS: Hybrid Tri-color bodywork for cheap
    By Speedmade in forum For Sale
    Replies: 4
    Last Post: 09-24-2015, 02:28 PM
  2. 851/ST4S hybrid
    By docandy in forum Projects
    Replies: 89
    Last Post: 05-10-2015, 04:23 PM
  3. 851/900SS Hybrid Engine
    By customhead in forum Technical Forum
    Replies: 8
    Last Post: 03-13-2015, 11:07 PM
  4. Is this a Hybrid...from Mexico
    By Isai46 in forum Technical Forum
    Replies: 1
    Last Post: 08-20-2013, 01:08 PM
  5. Which big end bearings...hybrid
    By lordmoonpie in forum Technical Forum
    Replies: 3
    Last Post: 08-03-2013, 04:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts